Hi, when I try to include AllanDeviation.hpp I get the following error:

/usr/local/include/gpstk/AllanDeviation.hpp:-1: In constructor 'gpstk::AllanDeviation::AllanDeviation(std::vector&, double)': /usr/local/include/gpstk/AllanDeviation.hpp:79: error: no matching function for call to 'sqrt(double&)'

need help here...


SOLVED-------

using gcc 4.7.3 on Ubuntu 13.04 I've needed to add std:: before sqrt on line 79 of AllanDeviation.hpp.

-- JacekRapinski - 12 Jul 2013
Topic revision: r1 - 12 Jul 2013, JacekRapinski
 

This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback